This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.


How do you fix your atom after seeing the word "unactive" in red in the top right corner?

Phil Woods
on 10/31/18, 5:17 PM 1,231 views

I've had my Atom phone for a couple of weeks now and my new phone is quite poorly.


The first sign that something was wrong was after installing the latest firmware. Shorty afterwards my phone kept resetting itself every hour or so. Initially I was slightly concerned that something was causing my phone to crash but other than that my new phone was working OK.


The next thing which starting happening was the same error message every two seconds about ‘Google Play services’ not responding. I searched online for various solutions and tried everything I could find such as reboots, clearing the app's cache, force stopping the app, reinstalling the app and nothing appeared to work. One online guide stated a factory reset might fix the fault.

So I've done a factory reset and my phone is now slightly worse off. After the factory reset the home button no longer functions and in the top right corner the word 'unactive' appears at all times and is in red. After restoring from backup everything seems fine for a few hours. Then my phone resets (I guess the same crash it’s always been experiencing). After a reset the phone always fails to boot and enters a screen titled 'Android Recovery' and gives me the options of ‘Try again’ or ‘Factory data reset’. ‘Try again’ always fails and shows a picture of a dead android whereas the ‘Factory data reset’ option does initially work until the phone crashes again or I manually initiate a reset.


Any ideas on how to fix? Or is my phone faulty?

On 12/13/18, 12:49 AM

Hello, I'm a front end developer, I have the same issue, Unactive, is still present and home button still doesn't work at all, it's definitely related to an" IMEI fault," this device use mtk Chip, it's a known issue, something went wrong into nvram during update or recovery!  , maybe unihertz support can provide both part of the factory recovery image..  We need to fix nvram.

  • Flag

I've contacted Unihertz support and they have provided me with detailed instructions on how to perform a factory reset with the image file.

I'm a games software engineer by trade so I'm used to following detailed instructions. After many hours struggling with poorly translated Chinese and installing drivers onto my PC I managed to flash my Atom. After flashing my Atom the phone appeared to be back to its factory state. The UI looked OK and the buttons worked.

I didn't install any apps on my Atom and just waited to see what would happen. Then the resets started happening again, I've put the phone away in a cupboard and will try again when I have the energy to try the phone again :'(

Phil Woods
on 12/13/18, 12:07 PM

Could you please elaborate what exactly did you do to bring phone back to its factory state. Flashed official rom using SPMultiPortFlashDownloadProject.exe? Or something else, any answer would be great help, because i tried everything and seem to stuck here.

on 3/17/19, 5:22 AM

Sorry for the delay in replying, it's been a while and I wanted to check whether my phone was working or is indeed faulty.

I flashed using an official rom using SPMultiPortFlashDownloadProject.exe. The trickest part with using SPMultiPortFlashDownloadProject.exe was making sure the drivers were installed correctly on my Windows PC. After flashing I could get my phone back into it's initial state.

Unfortunately my Atom never did work properly. I still have similar symptons as when I first got the phone. I've tried various different versions of the firmware as the new ones got released but my Atom still keeps regularly crashing. I tried using my Atom for three days last week and it seemed like the crashes were becoming less frequent, unfortunately the last crash corrupted the memory which means I'll have to flash again with SPMultiPortFlashDownloadProject.exe.

I'm going to request a refund or a replacement.

Phil Woods
on 4/8/19, 9:39 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!