Welcome!

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.

2

ATOM: sporadic reboots after update to 9.0

By
JonasR
on 8/15/19, 6:58 PM 936 views

(Edited to reflect status of trying to find solution: last: 2019-aug-29, see below):

Question:

I'm very happy with my Atom.

However, starting with the update from Android 8.1 to 9.0 and also after the first update to 9.0
I experienced sporadic reboots several times, with no apparent reason ..

It's not completely random, though: it always happend when I did not use the phone,
mostly overnight, but also during other longer non use times of 1 to several hours.

Everything else seems to work as before, with 8.1and 8.1 update:
I did not install additional apps, change settings, ..

Since it's very sporadic, it's difficult to tell the reason.
Will add to this post if I know more, see below.

Does anybody else experience this? Are there workarounds?
(it's weird if you expect a call or use the phone as a wake up clock ..)
-


Failed attempts:

1) I tried by turning off "intelligent energy saving in standby mode"
and thought this solved it, but unfortunately it did not.

2) One reboot the phone was plugged in (energy saving is off then),
so I guess energy saving is not the problem at all:
EDIT: I forgot that I turn off my power plug array over night,
so the phone was not charging. That brings me to attempt 7),
together with an answer from user UnderSky  (see below)

3) I deactivated the Google Carrier Services and uninstalled the Google app which
allows to start an app during inactive screen (Daydream): did not help.

4) I used WLAN (with still the above trials active), turned it off, turned LTE on,
rebooted and in the morning the device had rebooted (energy saving mode on).
After the reboot, google play told me updates are available.

5) Restarting the device (turn off, restart) with only LTE did not help either:
it rebooted again while in standby, overnight (reboot does not electrically turn off the device,
so I suspected bad WLAN hardware state to be the culprit: this is not the reason).

6) I now deactivated Google Play Store (but could not deactivate Google Play Services),
with only LTE on and restarted the device (shutdown, start, not only reboot).
This did not help: it rebooted 2 times during some few hours, daytime.
However, I rethought 2 and found an answer from user UnderSky below
also hinting to my next attempt 7)

7) I suspected unplugging from power (and whatever may follow,
switching back to energy saving, which Android 8.1 did not do) is the culprit.
I charged the device, unpluged, turned it off, restarted with only LTE active:
it still rebooted

8) I uninstalled Avira Antivirus.
It still rebooted.

9) I uninstalled Syncmate
It still rebooted (then reinstalled: after all this is my only phone ..)

10) Disabled USB debugging (which was needed for syncmate)
and increased log buffer size (will have to reenable USB debugging
for viewing them using adb, after a possible reboot and check
if I then can see logs from before the reboot).
>25h uptime but then reboot overnight.

11) Turned log buffers off and USB debugging on again.
System, Development options, Extended, Log buffers: off).
Installed Android 9.0 update from August 27
. Left settings as they were
Reboot 2.5 hours after the update ..

12) turned of USB debugging again to see if it influences uptime.
To have an electrically defined state, turned device off and on again.
Reboot overnight.

13) turned on intelligent energy saving in standby mode.
Reboot after less than 1h. turned off the mode and rebooted:
Android was hung during boot animation. Turned off/on: booted.

14) turned off and energy saving mode.  Turned off+on device
(to make sure energy saving mode did not place any hardware
in electrically bad state. Still it rebooted some hours later.

15) Reset device to factory settings (=9.0 update): it still rebooted
did not add account, not connect to WLAN, not install apps.

Next attempt:

Uptime is sometimes <1h, mostly some h, and rarely up to 25h:
I can't use a phone that reboots:
if I expect calls or use it as a waking clock, booting makes it useless.

I will now review if I can send it back to seller and get replacement
which hopefully is not broken or still has 8.1 / 8.1 update on it or works with 9.0.

I have sporadic reboots too 

Tried to turn off that intelligent energy saving but it didn't help

Have you changed battery usage settings for any of the apps? 

I may need to reset the device and try from scratch

Undersky
on 8/19/19, 1:36 PM

Unfortunately I had to edit my answer again:

it still reboots. I did not yet try resetting the device ..

All apps which show the setting do not offer enery optimization

or have set "not optimized".

JonasR
on 8/20/19, 9:04 AM

I reset the smartphone and it is better now, but reboots are not eliminated. Yesterday I had none, and I had hotspot turned on all day. 

This morning after full charge it rebooted sometime while I was driving to work.

I will try again but this time I won't install any apps on it, will wait and install one by one.

Undersky
on 8/22/19, 3:34 PM

I tried https://developer.android.com/studio/command-line/logcat

but unfortunately it did not show logs before the reboot (-L option: read error).

JonasR
on 8/25/19, 7:27 AM

0
Undersky
On 8/23/19, 1:38 PM

Yesterday I have reset the phone again, thankfully it is not my main phone (still hope it will though).

Did not install any applications, not connected to my google account, only updated google apps.

Put on charger in the evening, no reboots while on charger.

In the morning I removed from charger and put it in a pocket. I was driving for ~30 minutes and once parked I checked the phone and it had restarted.

Right now I've installed couple logging apps, not sure though they can catch the reboot cause though, but I'm giving them a try. If nothing helps I'm going to contact the seller for replacement, and if the replacement works the same way, then, well, it won't work for me, unfortunately.

  • Flag

I now suspect disconnecting from the charger being the culprit.

See above/will report in the status of the main question.

JonasR
on 8/24/19, 8:24 PM

Thanks for your answer: I had a thought about disconnecting too,

but was doubtful about it: you helped me formulate attempt #7.

JonasR
on 8/24/19, 8:40 PM

I "love" this little ATOM device:

I need glasses a little more often than with bigger phones,

but that's absolutely worth not having destroyed trousers,

and a rugged phone which has all the features I need, which also

supports me during garden work (dirt, water, view weather report), ..

I absolutely want to find a workaround, so the ATOM can continue

to be my phone (best ever, except for these reboots ..).

I am a software developer myself, so I am constructive

and try to find the thing that will help unihertz (or google?)

developers track down the problem in code and provide

an update and meanwhile help me keep this little nifty thing viable ..

JonasR
on 8/24/19, 8:49 PM

There is a way to use abp shell and access logs maybe you can try that.

It might be a defect too, it seems odd that we are the only two who has this issue.

Undersky
on 8/24/19, 9:22 PM

It actually reboots more often than I though

See here

https://photos.app.goo.gl/Wj1R8yqd2yry8T6Y6

Undersky
on 8/24/19, 9:25 PM

What I also tried - replaced the standard launcher (Quickstep) with the nova launcher. Didn't help either.

Undersky
on 8/24/19, 9:28 PM

I tried https://developer.android.com/studio/command-line/logcat

but unfortunately it did not show logs before the reboot (-L option: read error).

JonasR
on 8/25/19, 7:31 AM

I did reset from recovery menu, pulled out sim card - behavior didn't change, 6 reboots during this night.

Now I'm going to get replacement.

Undersky
on 8/25/19, 1:40 PM

That is weird. I didn't have usb debugging turned on, and I performed couple of resets which defaulted all settings.

Tomorrow arrives my replacement, will see.

Undersky
on 8/27/19, 5:11 AM

Got my replacement, downloading update from Aug 26th.

Undersky
on 8/27/19, 10:28 PM

Did the replacement work with 9.0?

JonasR
on 8/29/19, 10:53 AM

Replacement came with 8.1, updated with 27th update right away, 35 hours uptime so far, but this is without Sim card. Will try today with Sim card installed.

I also noticed that the boot menu (recovery) changed - now font size is much smaller. Not sure though was it part of firmware upgrade or a difference of replaced device.

Undersky
on 8/29/19, 10:57 AM

Did it work in the long run now?

JonasR
on 9/4/19, 9:05 AM

Yes, it works fine, no reboots

Undersky
on 9/14/19, 7:42 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!