Welcome!

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.

0

Windows USB driver for Atom & Jelly

By
Customer Service
on 2/25/19, 7:03 AM 3,670 views

Here is the google drive link of the MTK Driver Auto Installer.zip (Size: 28 MB )for those who need it:


1. Install the drivers.

2. For Windows 8 or newer, you may have to disable Diver Signature Verification.

3. Restart the computer after Driver installation.

4. Check Windows Device Manager to be sure Driver is installed correct.


 



0
Cathie
On 11/19/19, 5:06 PM

Jelly-Pro is recognized, but "This folder is empty."  Now what?



0
melow
On 9/23/19, 8:49 AM

Hi guys,

I spent 2 years not being able to connect my Jelly pro to my computer via USB with Windows 8.1 as OS, and I know many of you have the same problem (I remember the anger rising in the old forum). Here is a solution that worked for me:

  1. connect phone to computer via usb

  2. go to "Control panel" > "Device manager"

  3. right-click on the "Unknown device" and select "Update driver software..."

  4. click on "Browse my computer for driver software", set the software driver location to WIndows' \Inf folder (usually C:\\Windows\Inf) with option "Include subfolders" activated and click on "Let me pick from a list of device drivers on my computer"

  5. select "Android phone" in the list of device and press "Next"

  6. select "MTP USB Device" in the list and press "Next"

source: https://www.youtube.com/watch?v=0HbPZD1Bm4w





0
John Doe
On 8/9/19, 9:46 PM

^ Malware. Destroyed my hard drive. Thanks, aholes.



0
Domen
On 7/27/19, 8:10 PM

Hi, I am unable to connect my phone to my computer. I am using Windows 8.1 and Atom smartphone. When I start the instalation process from your file, Command Prompt tels me: "Do not support Win NT earlier version". I have also disabled Diver Signature Verification, but it still dose not work. I also tried to install the driver through "device manager" and "update driver software". This also dose not work. The sistem informs me that the task can not be completed because something in the "INF file" is not valid. What can I do? Please help.


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!