Welcome!

This community is for professionals and enthusiasts of our products and services. Share and discuss the best content and new marketing ideas, build your professional profile and become a better marketer together.

3

Background Apps killed After Android 9 update

eam
2019/8/15 下午9:18 6,531 浏览

Hi,

After Android 9 update I am not able to keep some apps active in background when you turn off the screen (phone in stand-by) stopping to receive notifications in apps like Whatsapp for Business, Outlook with an Exchange account.

I have already tried to turn off "Battery management" and to set for these apps "dont optimize the Battery" but all these settings not work.

With Android 8 it was present in settings "Power safe manager" in order to have these apps active in standby mode but this menu item is not present anymore in Android 9 settings.

Please help to find a solution, for sure it affects all users.


4
Bas
2019/8/16 下午12:16

You need to do 2 things:

- Go to Android settings > Smart Assistant > Appblocker. There you can choose: 1) switch off the Appblocker, or 2) Give exceptions to particular apps.

- Go to Android settings > Duraspeed  and again to options: 1) switch off Duraspeed or 2) Give exceptions to particular apps.

Hope this helps.



Hi Bas,

I have turned on both items and used the option 2) for both of them. After 4 hours of test It seems that it is working good. Thanks for the suggestion. I'll reply again in the case the "problem" will come up again

eam
2019/8/16 下午4:58

-1
Robs
2019/11/29 下午4:33

Perfect, thank you Bas,

it did the trick. I am getting my notifications on my smart watch with my Unihertz Atom!



你的回复

请尽量给予实质性答复。 如果你想在问题或答案发表评论, 请 使用评论工具。 请记住,你可以随时修改你的答案 -无需回答同样的问题两次。另外,请不要忘了投票 -它确实有助于选择最佳的问题和答案!